Esko Logo Back to Esko Support
Choose your language for a machine translation:
Skip to end of metadata
Go to start of metadata

 

Question

Do the existing Esko plugins (DeskPack - Dynamic Content - Studio) support the latest Adobe® Creative Cloud release?

Answer

No, not by default! Each new Adobe release requires Esko to release new compatible plugins and installers.

If you use any Esko plugin, we strongly recommend to not update your Adobe® Illustrator® or Adobe® Photoshop® until the list below states that they are fully supported.

Updating Adobe® Illustrator® or Adobe® Photoshop®

If you need to update your Adobe® application before you have compatible Esko plugins, then remember the following:

  • The Adobe® installation program will by default remove the previous version. So, to make sure that you still have a version with working plugins, please make sure to disable Remove old versions in Advanced Options. For more information, see http://adobe.ly/1SkeMvy or check this screenshot (it was written for an earlier update).
  • If you have already removed your previous version of Adobe® Illustrator® or Adobe® Photoshop® and you need your Esko plugins, then you will have to downgrade Adobe® Illustrator® or Adobe® Photoshop® and reinstall your Esko plugins. This blog article from Adobe® explains the downgrade process (it was written for an earlier update).
Product

Adobe Creative Cloud
CC2019
NEW

Adobe Creative Cloud
CC2018

Adobe Creative Cloud CC2017

Adobe Creative Cloud CC2015.3

Adobe Creative Cloud CC2015Adobe Creative Suite CS6
DeskPack for Illustrator

SUPPORTED as of 18.0.1

SUPPORTED as of 16.1.2

SUPPORTED as of 16.0.2

SUPPORTED  as of 16

NOT SUPPORTED as of 16.1.2

SUPPORTED as of 12.0 Assembly 2
DeskPack for Photoshop

SUPPORTED as of 18.0.1

SUPPORTED as of 16.1.2

SUPPORTED as of 16.0.2
SUPPORTED  as of 16

NOT SUPPORTED as of 16.1.2

SUPPORTED as of 12.0 Assembly 2
Dynamic Content

SUPPORTED as of 18.0.1

SUPPORTED as of 16.1.2
SUPPORTED as of 16.0.2
SUPPORTED  as of 16

NOT SUPPORTED as of 16.1.2

SUPPORTED as of 12.0 Assembly 2
Studio

SUPPORTED as of 18.0.1

SUPPORTED as of 16.1.2

SUPPORTED as of 16.0.2

SUPPORTED  as of 16

NOT SUPPORTED as of 16.1.2

SUPPORTED  as of 12.0 Assembly 2
WebCenter Connector

SUPPORTED as of 18.0.1

SUPPORTED as of 16.1.2
SUPPORTED as of 16.0.2
SUPPORTED  as of 16

NOT SUPPORTED as of 16.1.2

SUPPORTED as of 12.1.2 Assembly 5

ai-cut

SUPPORTED as of 18.0.1

SUPPORTED as of 16.1.2
SUPPORTED as of 16.0.2
SUPPORTED  as of 16

NOT SUPPORTED as of 16.1.2

SUPPORTED as of 12.1.1 Assembly 4

For more information, please also visit our System Requirements page: https://www.esko.com/en/systemrequirements/

Article information
Applies to

DeskPack

Dynamic Content

Studio

WebCenter Connector

ai-cut

Created
 
Last revised

AuthorSDME
CW Number 
Contents