Esko Logo Back to Esko Support
Choose your language for a machine translation:
Skip to end of metadata
Go to start of metadata

Description

Color Pilot 16.x and higher is lacking icc export functionality. This KB explains how to create an icc profile with X-rite i1Profiler using an Esko profile.

Procedure

i1Profiler license

i1Profiler can be downloaded for free from the X-rite website: https://www.xrite.com/service-support/product-support/formulation-and-qc-software/i1profiler
A connected i1 device will unlock some features but the profile creation feature of i1Profiler requires a license.
Check on the homepage of i1Profiler which license you have (depends on the bought i1 solution).

Example of a basic licensed i1Profiler:

Example of a fully licensed i1Profiler:


Check this PDF for more info (see page 14):
https://www.xrite.com/-/media/xrite/files/literature/l7/l7-500_l7-599/l7-519_i1professional_solutions/l7-519_i1family_en.pdf
In order to make a CMYK or CMYK+ profile you need the following feature:

Contact X-rite for information about how to upgrade if you're missing this feature.

The procedure consists of two main steps:

  • Exporting the measurement data of an Esko profile
  • Creating an icc profile

Export measurement data of an Esko profile

  1. Open the Color Pilot.
  2. Select the profile you want to make available as icc profile.
  3. Right click and choose Export.
  4. Save as type CGATS file format.

Creating a CMYK icc profile

  1. Open i1Profiler (make sure a compatible device is connected).
  2. Switch to the Advanced User Mode.
  3. Select the correct ink set below the printer workflow icon, Device selection.
  4. Click the Profiling button.
  5. Click the Load button and browse to the CGATS file saved in Color Pilot (make sure you select "CGATS files (*.txt) as file format).
  6. Select the correct measurement condition (you can find out the measurement condition by double clicking the Esko profile in Color Pilot, this will open the Profile Information window which shows on the right the measurement condition) and click OK.
  7. Select Unknown for both options in the Import and Convert Measurements window.
  8. Skip the Test Chart step and click the Measurement button.
  9. Click the Load button and browse to the CGATS file saved in Color Pilot (make sure you select "CGATS files (*.txt) as file format).
  10. Select the correct measurement condition.
  11. Select Unknown for both options in the Import and Convert Measurements window.
  12. Skip the Lighting step and click the Profile Settings button.
  13. Select Large for the Size A to B and Size B to A options.
  14. Click the ICC Profile button.
  15. Enter a file name and click the Save Profile button.

    Disable the Include CxF data option if you want icc profiles with a smaller file size. This has no impact on the color accuracy of an icc profile.

Creating a multicolor icc profile


i1 Profiler limitation

i1Profiler can't use more then 6000 patches! Due to this limitation it might not be possible to use certain Esko CGATS. You'll get the following error message when i1Profiler detects more then 6000 patches:


  1. Open i1Profiler (make sure a compatible device is connected).
  2. Select the correct ink set below the printer workflow icon, Device selection.
    (e.g. select CMYK+one printer when importing CMYKG CGATS data)
  3. Click the Profiling button.
  4. Define the Lab of the extra color (use either Color Pilot or search in the CGATS file for the Lab value of the solid of the extra color)



  5. Click the Load button and browse to the CGATS file saved in Color Pilot (make sure you select "CGATS files (*.txt) as file format)
  6. Select the correct measurement condition (you can find out the measurement condition by double clicking the Esko profile in Color Pilot, this will open the Profile Information window which shows on the right the measurement condition) and click OK.
  7. Select Unknown for both options in the Import and Convert Measurements window.
  8. Skip the Test Chart step and click the Measurement button.
  9. Click the Load button and browse to the CGATS file saved in Color Pilot (make sure you select "CGATS files (*.txt) as file format).
  10. Select the correct measurement condition.
  11. Select Unknown for both options in the Import and Convert Measurements window.
  12. Skip the Lighting step and click the Profile Settings button.
  13. Select Large for the Size A to B and Size B to A options.
  14. Click the ICC Profile button.
  15. Enter a file name and click the Save Profile button.

    Disable the Include CxF data option if you want icc profiles with a smaller file size. This has no impact on the color accuracy of an icc profile.

Tips for using an icc profile in Adobe® Photoshop®

If you want to use Photoshop to see how an image will look like when printed according to the printing condition as specified in an icc profile, use the following settings:

  1. Edit > Color Settings.
  2. Conversion Options > Intent > select Absolute Colorimetric.
  3. Edit > Assign Profile.
  4. Select the icc profile and enable the Preview option.
Article information
Applies to

Color Pilot 16.x

Created

 

Last revised

 

AuthorSDOB
Case Number
Contents