Child pages
  • Neo 10.1.4 System Requirements
Skip to end of metadata
Go to start of metadata

The following are the minimum system requirements for Neo 10.1.4. Exceeding these requirements will in most cases lead to a performance increase. Running Neo on a system that does not meet these requirements is not supported.

Minimum requirements for Neo

Minimum System Requirements for Neo
Processor type and speedMac Intel processor.
RAM

Minimum 2 GB RAM.

Available hard drive space

  • System drive
  • Data drive
The software takes about 1GB of disk space. Also take into account the need for storage of temporary and production data. A backup solution is strongly advised.
Minimum screen resolutionMinimum 1280 x 1024 resolution, true color depth.
Internet connection10/100/1000 Base-T Ethernet, TCP/IP v4 protocol, TCP/IP v6 protocol is not supported.

Supported Operating Systems

Recommended operating systems are highlighted in the tables below.

If an operating system is not listed in the tables below, it is not supported. Do not try to install Neo on a computer running an unsupported operating system.

Mac OS

EditionClient OS
10.11 (El Capitan)      (tick) *
10.10 (Yosemite)(tick)

10.9 (Mavericks)

(tick)

10.8 (Mountain Lion)

(tick)
10.7 (Lion)(tick)
10.6.0 - 10.6.8 (Snow Leopard)(error)
10.5.0 - 10.5.8 (Leopard)(error)

*For Neo 10.1.4 to work on El Capitan, you do need to use the new Neo installer that was released on February 9, 2016. See mysoftware.esko.com.

 

 

The server versions of these operating systems are not supported.

System Requirements
Applies toNeo
Version10.1.4
Last revised9-Feb-2016

Useful Links

Software downloads: mysoftware.esko.com

Contents