Exploring the Pattern Editors

Introduction

With an almost infinite number of possible case sizes and the many different pallet pattern styles available within the CAPE PACK palletizing calculations, there are literally hundreds of ways of arranging cases onto a pallet layer.

The palletizing algorithms have been designed to find the maximum number of cases per layer. However, you may decide that the positioning of the cases or the nature of the pattern interlock is not the most appropriate or stable for your production or handling system. This is particularly true when the "case length to case width ratio" is 2:1 and numerous pairs of cases can be turned 90° to provide many different pattern styles.

To overcome this particular problem and other potential pattern layout problems, CAPE PACK is supplied with powerful 3D Pattern Editors – Layer Editor for the single product programs and Load Editors for Display Pallet.

Layer Editor

The Layer Editor provides a simple, yet very realistic, way for you to move, rotate and reposition cases within a single pattern layout to suit your exact needs. You can also add or delete layers from a pallet load.

Alternatively, you may wish to use the Layer Editor to edit the layout of the cases to produce different layers with the same number of cases per layer.

Either way, the Editor allows you to modify a pattern layer quickly and then construct your full pallet load.

Once a pattern has been edited it can be reviewed in an on-line mode in the Multi-Viewer Graphics. The pattern can then be saved and recalled at a future date.

You cannot edit layers in the Layer Editor if you have chosen either None or No Package as your package type.

Editing Layers

Select Layer Editor from the Edit menu in Multi-Viewer Graphics.

The Layer Editor consists of a top-view Pattern Editor on the right hand side of the screen and the ability to view the pallet load in a 3-D Viewer on the left-hand side.

You can select the Editor window by clicking on the little circle marked Edit.
The Editor window displays a top-view of your selected pattern. This window is used for editing and manipulating the cases within the layer pattern.

The Viewer window is used to look at the layer pattern in the load you are editing. Thus, you can see the changes you make to the layer pattern as they happen simply by choosing **Edit** or **View**. You can also use the Viewer window to examine your edited pattern in a variety of different formats.

If you select **Edit**, the screen changes to the editing mode with just a single layer in the viewing box.
The Layer Editor Window always displays a single layer, top-view of the pallet pattern. If you need to create an alternate layer that is not a normal alternated or flipped layer, you can create a second layer pattern.

**Viewer Toolbar**

In addition to the standard pull down menus, the Layer Editor provides a convenient set of buttons for accessing the most commonly used Viewer Window options. Here is a description of the Viewer Toolbar functions.

- 0°: Sets the viewing orientation to 0°
- 90°: Sets the viewing orientation to 90°
- 180°: Sets the viewing orientation to 180°
- 270°: Sets the viewing orientation to 270°
- 1: Shows side 1 of the load
- 2: Shows side 2 of the load
- 3: Shows side 3 of the load
- 4: Shows side 4 of the load
- New: Allows an existing pattern to be used to create an entirely new pattern
- Copy: Duplicates a pattern, creating an additional layer
- Up: Moves a selected layer up in the pallet load
- Down: Moves a selected layer down in the pallet load
- Delete: Deletes the highlighted layer in the list box
- Flip: Allows the pattern to be flipped in the length, width or both directions

**Selecting Cases**

The Layer Editor uses a Windows technique for manipulating objects on the screen. This allows you to treat a case as if it were a real object. You can pick it up, rotate it or slide it around. There is also the ability to move several cases together (a “block of cases”) as if they were a single case.

However, the Editor options which manipulate cases affect only the selected item in the load. A selected item is indicated with a large X drawn on top of it.

**Selecting a Single Case**

To select a single case move the mouse cursor over the case you want and click on the left mouse button.
Selecting a Block of Cases

A “block of cases” is a group of cases stacked together in the same orientation. This method provides a very effective and efficient way to perform editing functions on more than one case at the same time. This feature eliminates the need to do things repetitively.

Press and hold down the **Shift** key, place the cursor over the first case you want to select and press and hold the left mouse button.

Now drag the mouse pointer to the last box to be included. The dotted line you are drawing is called the Selection Rectangle.
Release both the mouse buttons and the **Shift** key. The block becomes selected.

Having selected a block of cases, you can now use any of the available Editor functions. An X drawn through them indicates the cases included in the block. This technique is sometimes referred to as “elastic banding”. **Only those cases that are near to one another and are in the same orientation can be selected into a block.**

### Moving Cases

Moving a case or block of cases is a simple process. After you have selected a case or block of cases, click and hold down the left mouse button and move the pointer to the position where you want the case/block of cases to be placed.

Select the case or block of cases.
While pressing down the left mouse button, drag the box to the required position.

Release the mouse button to stop the movement of the case or block of cases.
Lifting Cases

This lifting technique is similar to moving a single case but requires you to press and hold both mouse buttons at the same time and then drag to the new location.

Select the case with the left mouse button, now hold down both the left and right mouse buttons together.

Drag the case to the required position.
Now release both mouse buttons to drop the case into the required position.

You cannot lift a case if another case is above it. However, you can slide the case or block of cases from side to side if there is sufficient room available.

### Rotating Cases

The Editor provides the ability to rotate individual cases.

Select a case, using your mouse.
Press the **right or left arrow keys** on your keyboard to rotate the selected case in the direction you require.

If there is not enough room to rotate the case where it is located, the program will lift it up over the cases near it and turn it.
Creating New Layer Patterns

The Layer Editor allows you to create as many layer patterns as you like with a different layout to that of the first layer pattern. This option allows you to create unique alternate layers that will make up your final pallet load.

Most users will not need a unique second pattern since they simply want all their layer patterns to be the same layout as their first pattern, just flipped in a particular fashion.

If you do want your alternate layers to have a different pattern layout you will need to create a new layer pattern before you exit the Editor.

Once you have completed editing and creating your first pattern, click on the View selector, and then the New button. The following box appears.

You can select a new layer pattern from the list provided (P001, P002, etc.) by selecting the “Use PXXX” feature.

Or you can create your own new layer based on one of the patterns in the list. Click on the layer of your choice and then the Create button.
Either way, once you choose, the control returns to the Editor. As you create new layers, you will notice that your pallet load grows. If you do not want to expand the height of your pallet, simply use the **Delete** button to delete the unwanted layers.

Select **Edit** to change the pattern of your choice.
When you have completed editing your second, third, fourth (or however many different layers you want), you can select the **View** mode to review your load or move layers up/down.

When finished, select **Close** from the **File** menu. The following screen will appear.
Click **Yes** to save your changes, **No** to exit without saving or **Cancel** to return to the Editor. If you select **Yes**, you will be returned to Multi-Viewer Graphics and you will see the pallet load with your edited layers.

---

**Adding Cases**

Just highlight one case by clicking on it.

Then hold down the **CTRL** key and click on the case again. This will automatically add one case on top of the highlighted case.
Now move the new case to the chosen location.

Expanding Overhang

Click on the Options menu and then Reset Overhang.
The following screen appears.

Enter in the total amount of overhang you want in the length and width and click on **OK**. The pattern will reappear with a border around the layer that represents the new boundaries of the load.

The program will retain the last overhang amount entered as the default.

Make whatever changes you need and then exit the Layer Editor. The load will automatically center when you exit back to Multi-Viewer Graphics.

If you don’t want the load to center, click on the **Options** menu and **Do not center pattern on Exit**.
Deleting Cases

Just highlight a case and hit the **Delete** key on your keyboard. The case will be removed.

Deleting Layers from your Load

Click on the **View** field and you will see the full pallet load.

Highlight a layer and click on the **Delete** button.
The pallet now has one less layer.

**Copying Layers**

To copy a layer, click on the layer in the list you want to copy and click on the **Copy** button.

The Editor will make a duplicate of that layer.
Moving Layers up or down in the load.

To move a layer up, click on the **Up** button. The layer will move up 1 level for each click on that button.

To move a layer down, repeat this process using the **Down** button.
Display Pallet Load Editor

The Display Pallet Load Editors are powerful program utilities that allow you to create and edit different loads. These special Editors allow for adding or deleting packages, building or moving individual or blocks of boxes on the pallet and generally creating a load as if you were physically placing the boxes onto the pallet.

The Editors use simple drag-and-drop techniques to give natural control over the placement of the boxes within the load. A number of additional features are available for you to quickly and easily customize your pallet load. Once you have finished editing/building your load, the results can be printed or saved.

You can choose the Display Pallet editors in two ways:

- You can start with an empty pallet and build your own load. Choose to start with an editor via the **Calc. Settings** button. If you choose this option, the program will not calculate any loads for you automatically. It will take you directly to the selected editor option when you select to calculate the load.

- You can calculate your loads, go to the on-screen graphics and use the editors to customize or modify the layout of the case/trays in your pallet load.

Calculation Settings Button

- To access the Editor from the **Calc. Settings** button and use it to totally design your load, click on the **Calc. Settings** button.

The following screen appears.

![Calc. Settings](image)

Click on the **Column Editor**, **Layer Editor** or **Mixed Load Editor** selector. Then click on **OK**.
Choose one of the calculate options from the File menu. You will be presented with an empty pallet ready to start building.

To access the Editor from Multi-Viewer Graphics after Display Pallet has calculated solutions for you, select the load you wish to edit.

Click on the Edit menu, then Load Editor.

The Load Editor window will open.
For simplicity in this chapter, the word “boxes” will be used to describe boxes, cases and trays of products.

Editor and Viewer Windows

Notice the Load Editor has two open windows.

- The Viewer window is used to look at the load being edited from a variety of angles, with or without the labels, control faces or box types.

- The Editor window is used for manipulating, adding or deleting boxes. Boxes cannot be selected in the Viewer window. It is for viewing only.

Viewer Toolbar

In addition to the standard menus, the editor provides a convenient toolbar for accessing Viewer window functions. The toolbar resides on the left side of the Viewer window. The following table provides a summary of these functions.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0°</td>
<td>Sets the orientation to 0 degrees corner.</td>
</tr>
<tr>
<td>90°</td>
<td>Sets the orientation to 90 degrees corner</td>
</tr>
<tr>
<td>180°</td>
<td>Sets the orientation to 180 degrees corner</td>
</tr>
<tr>
<td>270°</td>
<td>Sets the orientation to 270 degrees corner</td>
</tr>
<tr>
<td>1</td>
<td>Shows side one of the load</td>
</tr>
<tr>
<td>2</td>
<td>Shows side two of the load</td>
</tr>
<tr>
<td>3</td>
<td>Shows side three of the load</td>
</tr>
<tr>
<td>4</td>
<td>Shows side four of the load</td>
</tr>
<tr>
<td>A</td>
<td>Toggles between color and outline modes</td>
</tr>
<tr>
<td></td>
<td>Turns the labels on and off</td>
</tr>
<tr>
<td></td>
<td>Turns the control faces on and off</td>
</tr>
<tr>
<td></td>
<td>Turns the types on and off</td>
</tr>
</tbody>
</table>
Editing Loads

The editor supports a Windows technique for manipulating objects called “drag-and-drop.” This technique treats a box on your screen like a real object. The object can be picked up, stacked, slid around, duplicated or even deleted. Other features supported in the editor include:

- The ability to manipulate blocks of boxes as a single box.
- The option to automatically create a full stack of boxes from a single box.
- The ability to rotate a box or block.
- A range of useful editing and viewing techniques.

A block of boxes is defined as a group of boxes in the same orientation and which are stacked together. A block can be created by using the selection rectangle procedure described in this section.

Selecting a Box

Each of the functions in the Editor, which allow manipulation of a box or block of boxes, will affect the selected item in the load. Just select a box (case or tray) or block and then perform the desired function on it.

Click on the box using the left mouse button. The selection status of an item is illustrated by the following pictures:

Unselected item

Selected item

Selecting a Block of Boxes

Sometimes a function, such as Move or Copy, will need to be performed on a group of boxes simultaneously. Multiple box selection is easily accomplished by using the “Selection Rectangle” feature.

In the Column Editor, blocks can be selected which extend in three dimensions. For example, the number of boxes that make up a block could be one box wide, three boxes long and four boxes deep, for a total of 12 boxes selected (1 x 3 x 4). Since loads made up of layers consist of separate layers of boxes (cases/trays), blocks cannot be selected with more than a depth of one box in the Layer Editor.

Press and hold down the Shift key.

Click and hold the left mouse button on the first box in the block and drag the mouse pointer diagonally to the last box to be included. The mouse pointer becomes a cross-hair indicator. A dashed rectangle should be drawn over the boxes as the mouse is moved.

Release the mouse button and the Shift key. The Editor will automatically select the largest block possible within the given rectangle. The boxes that were included in the block will now be shown with a diagonal selection mark (or cross).
The editor will select the largest block possible. All the boxes to be defined as a block must be of exactly the same type and orientation. In order to define a block, all the boxes must be touching or stacked together as a group.

To determine how many layers deep the selection covers, refer to the list box in the upper-left corner of the Editor Window. Remember that blocks can be selected with a depth greater than one only in the Column Load Editor.

![List Box](image)

The list box above indicates that 8 layers are selected in the block. Simply selecting a different number from this list box can change the number of layers selected in the block. For example, if (2) is selected from the list box, the block automatically becomes only two layers deep.

Once a block has been selected, the usual editing functions are available.

### Placing a New Box onto a Pallet

1. Make the Editor window active by clicking in it.
2. From the View menu, choose Select Box.
3. From the resulting small window, click on the type of box and orientation desired.
4. Click on the pallet where the box is to be placed. An open space on the pallet must be selected.

![](image)

### Copying a Box or Block

Making a copy of a box or block is very easy. The procedure is similar to that for moving an object, except that the Ctrl (Control) key must be held and kept down before selecting the box or block.

1. Identify the box or block to be copied, then press and hold down the Ctrl key, and click on the box or block.
2. Release the Ctrl key and the left mouse button. The new box or block will appear on top of the original box or block.

### Moving a Box or Block

Moving a box or block is a natural extension of selecting the object.

1. Once the block has been selected, click and drag the block to the new location.
When the block is in position, release the mouse button.

Lifting a Box or Block

The process of lifting a box or block is similar to moving the object. However, instead of clicking and dragging with the left mouse button, use **both mouse buttons at the same time** to lift the object.

Click on the box or block to be lifted **with both mouse buttons**.

Drag the block to the new location and release both mouse buttons.

A box or block cannot be lifted if there is another box or block above it.

Creating Gaps within a Block

To create evenly spaced gaps within a block of boxes:

Select the block to be gapped.

Move the mouse pointer to the edge of the selection. It will turn into a **double-headed arrow**.

When the arrow is double-pointed, hold the left mouse button and drag the mouse outwards.

When the left mouse button is released, the boxes will be spread out with even gaps between the boxes.

Function Keys in the Load Editors

The options listed above give the power to create and modify pallet loads to meet defined specifications. The Editor, however, provides a number of function keys that make the creation of loads even easier. Here is a description of those function keys.

<table>
<thead>
<tr>
<th>Function Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Up</td>
<td>Creates a stack of the maximum allowed height from the selected box (case/tray).</td>
</tr>
<tr>
<td>Page Down</td>
<td>Reduces a selected block to a single box in height.</td>
</tr>
<tr>
<td>Left Arrow (←)</td>
<td>Rotates the selected object 90° in a counterclockwise direction. There must be space available for the box in its new orientation.</td>
</tr>
<tr>
<td>Right Arrow (→)</td>
<td>Rotates the selected object 90° in a clockwise direction. There must be space available for the box in its new orientation.</td>
</tr>
<tr>
<td>Up Arrow (↑)</td>
<td>Adds one box to the selected block if space is available.</td>
</tr>
<tr>
<td>Down Arrow (↓)</td>
<td>Removes one box from the selected block (down to one).</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected box or block from the load.</td>
</tr>
<tr>
<td>Shift</td>
<td>Used with the mouse to select the block within the selection rectangle.</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>Used with the mouse to copy a box or block.</td>
</tr>
</tbody>
</table>

Fine Tuning Movements

To fine tune any movements of boxes or blocks:

Select a box or block.

Press and hold the **Alt** key, then use the four arrow keys to move the selected box or block.

The selected object will jump to the next adjacent box or intersection of boxes. This method makes it easy to ensure that the object is lined up precisely with the other boxes already on the pallet.
Up and Down Buttons

The up and down arrow buttons pictured below have different functions depending upon which Editor is being used.

![Up and Down Buttons](image)

UP Arrow

- In the Layer Editor, this button will make the next **higher** layer active.
- In the Column Editor, this button will build all stacks in the load to the maximum height allowed according to your specified maximum load height.

DOWN Arrow

- In the Layer Editor, this button will make the next **lower** layer active.
- In the Column Editor, this button will reduce all stacks in the load to a single box high in each column.

Load Restrictions Violations

When saving a load, the Editor automatically checks the load for conformity to the restrictions and specifications defined for the current problem. If the load violates any of the problem restrictions, a window detailing the violations will appear. This feature stops you from creating unrealistic loads that do not abide by your specified loading requirements, i.e. maximum weight and height restrictions.

The violations listed are of two types:

- Blue violations are warnings that the load you have created differs from your original specifications or restrictions. The edited load can still be saved.
- Red violations are far more severe; a load **cannot be saved which contains any red violations**.

At any time during the creation of a pallet load, you can check the load for conformity by selecting **View Restrictions** from the **View** menu and looking at the information provided.

Layer Editor Dialog Box

Since loads made up of layers often require different characteristics from column or mixed loads, the Layer Editor dialog box is only accessible from the **Layout** menu when you are in the Layer Load Editor.

Select the **Layout** menu, then **Layer** to display the following window.
This feature offers a variety of functions that can help you modify and arrange layers within the load. Here is a list of the button functions available.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>New</strong></td>
<td>Creates a new layer and makes it the active layer.</td>
</tr>
<tr>
<td><strong>Copy</strong></td>
<td>Copies the selected layer and makes it the active layer.</td>
</tr>
<tr>
<td><strong>Up</strong></td>
<td>Moves the selected layer up one position on the pallet.</td>
</tr>
<tr>
<td><strong>Down</strong></td>
<td>Moves the selected layer down one position on the pallet.</td>
</tr>
<tr>
<td><strong>Delete</strong></td>
<td>Deletes the selected layer.</td>
</tr>
<tr>
<td><strong>Flip Buttons</strong></td>
<td>These buttons, <strong>Length</strong>, <strong>Width</strong>, <strong>Both</strong>, cause the selected layer to flip over in that direction.</td>
</tr>
<tr>
<td><strong>Center</strong></td>
<td>Causes the selected layer, as a whole, to be centered on the pallet.</td>
</tr>
<tr>
<td><strong>Pad Check Box</strong></td>
<td>Inserts a layer pad beneath the selected layer.</td>
</tr>
<tr>
<td><strong>New</strong></td>
<td>Creates a new layer and makes it the active layer.</td>
</tr>
</tbody>
</table>

**Menu Options**

Many additional editing functions are available from the toolbar menus at the top of the window. These are described below.

<table>
<thead>
<tr>
<th>Menu</th>
<th>Function Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File Menu</strong></td>
<td><strong>Print</strong> Allows the setting of printing options and printing of the load displayed in the Viewer and Editor windows.</td>
</tr>
<tr>
<td></td>
<td><strong>Print Preview</strong> Displays a scaled version of the Viewer window as it will appear on the final printed output.</td>
</tr>
<tr>
<td></td>
<td><strong>Print Setup</strong> Allows the selection of printer configuration options available for your printer driver.</td>
</tr>
<tr>
<td></td>
<td><strong>Save and Update</strong> Saves the load currently being edited using the same filename that load had (prior to entering the Editor). This method saves your changes over the original load.</td>
</tr>
<tr>
<td></td>
<td><strong>Save as New Load</strong> Saves the current load being edited using a different filename from the one loaded into the Editor. This method does not change the original load information.</td>
</tr>
<tr>
<td></td>
<td><strong>Close</strong> Quits the Load Editor and returns to Display Pallet.</td>
</tr>
<tr>
<td><strong>Layout Menu</strong></td>
<td><strong>Clear All Boxes</strong> Deletes all of the boxes on the pallet. You cannot get the boxes back once they have been deleted unless you leave the Editor.</td>
</tr>
<tr>
<td></td>
<td><strong>Layer</strong> Shows the Layer Editor dialog box for manipulating layer loads.</td>
</tr>
<tr>
<td></td>
<td><strong>Columns to Min</strong> Reduces all columns in the load to a single box in height.</td>
</tr>
<tr>
<td></td>
<td><strong>Columns to Max</strong> Builds all columns in the load to their maximum height.</td>
</tr>
<tr>
<td></td>
<td><strong>Center Load</strong> Allows you to center the load, as edited, between sides 1 and 3 of the pallet, sides 2 and 4 of the pallet, or both.</td>
</tr>
<tr>
<td></td>
<td><strong>Shift</strong> Moves the active layer or column as far as possible to either the left, right, top or bottom sides of the pallet.</td>
</tr>
<tr>
<td><strong>View Menu</strong></td>
<td><strong>Select Box</strong> Displays a window containing the box types (cases, cans/bottles/cartons in trays etc.) that were defined for the current problem. Select a box for placing in the load.</td>
</tr>
<tr>
<td></td>
<td><strong>Status Bar</strong> Turns the status bar at the bottom of the Editor on or off.</td>
</tr>
<tr>
<td></td>
<td><strong>View Restrictions</strong> Checks the current load for violations of the load restrictions and specifications you defined for the current problem.</td>
</tr>
<tr>
<td><strong>Statistics</strong></td>
<td>Displays a spreadsheet of statistical information about the load.</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Auto Update</strong></td>
<td>Turns the automatic update status of the Viewer window on or off.</td>
</tr>
<tr>
<td><strong>Window Menu</strong></td>
<td><strong>Cascade</strong></td>
</tr>
<tr>
<td><strong>Tile</strong></td>
<td>Arranges the open windows in a tiled fashion. This is the default mode.</td>
</tr>
<tr>
<td><strong>Editor</strong></td>
<td>Makes the Editor window active for manipulating boxes.</td>
</tr>
<tr>
<td><strong>Viewer</strong></td>
<td>Makes the Viewer Window active for showing different angles of the edited load.</td>
</tr>
<tr>
<td><strong>Help Menu</strong></td>
<td><strong>Contents</strong></td>
</tr>
<tr>
<td><strong>About Load Editor</strong></td>
<td>Displays information about the current Editor.</td>
</tr>
<tr>
<td><strong>File Menu</strong></td>
<td><strong>Print</strong></td>
</tr>
<tr>
<td><strong>Print Preview</strong></td>
<td>Displays a scaled version of the Viewer window as it will appear on the final printed output.</td>
</tr>
</tbody>
</table>