Child pages
  • DeskPack Plugins for Adobe® Photoshop® 18.1 System Requirements

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Updated by Esko.Confluence integration from workflowwiki


The following are the minimum system requirements for DeskPack Plugins for Adobe® Photoshop® 18.1 and Equinox 18.1. Exceeding these requirements will in most cases lead to a performance increase. Running DeskPack Plugins for Adobe® Photoshop® or Equinox on a system that does not meet these requirements is not supported.

A list of available Plugins can be found here:

DeskPack - Which installer contains what plugin

Minimum requirements

DeskPack Plugins for Adobe® Photoshop® 18.1 (Mac)

Minimum System Requirements for DeskPack Plugins for Adobe® Photoshop® 18.1 (Mac)
Processor type and speed

64-bit Intel® processor.

RAM

4 GB minimum, recommended is 16 GB RAM.

 

Available hard drive space

  • System drive
  • Data drive

The software takes about 2 GB of disk space. Also, take into account the need for storage of temporary and production data. A backup solution is strongly advised.

Minimum screen resolutionMinimum 1280 x 1024 resolution, true color depth.
Network connection10/100/1000 Base-T Ethernet, TCP/IP v4 protocol, TCP/IP v6 protocol is not supported.
Software requirements

DeskPack for Adobe® Photoshop® requires Adobe® Photoshop® CC 2017, CC 2018, CC 2019, or CC 20192020.

From 18.1 onwards, Adobe® Photoshop® CS6 is no longer supported. (*)

From 18.1.1 onwards, Adobe® Photoshop® CC 2017 is no longer supported and CC 2020 is supported. (*)

(*) More information on supported Adobe® Photoshop® versions can be found in the following knowledge base article: KB193116287: Do the Esko plugins (DeskPack - Dynamic Content - Studio) support the latest Adobe Creative Cloud release.

Supported Operating Systems

Tip
Recommended operating systems are highlighted in green in the tables below.


Warning

If an operating system is not listed in the tables below, it is not supported. Do not try to install DeskPack Plugins for Adobe® Photoshop® on a computer running an unsupported operating system.

Mac OS

EditionClient OS
10.15 (Catalina)      (tick)*
10.14 (Mojave)(tick)
10.13 (High Sierra)(tick)
10.12 (Sierra)(tick)
10.11 (El Capitan)(error)
10.10 (Yosemite)(error)

 *Catalina is supported from 18.1.1 onwards.

Note
The server versions of these operating systems are not supported.Note that version 18.1.1 is the last version to support macOS X 10.12 (Sierra).

DeskPack Plugins for Adobe® Photoshop® 18.1 (Windows)

Minimum System Requirements for DeskPack Plugins for Adobe® Photoshop® 18.1 (Windows)
Processor type and speed

x64 (64-bit) compatible dual-core processor (Intel® or AMD®), minimum dual-core.

RAM

4 GB minimum, recommended is 16 GB RAM.

Available hard drive space

  • System drive
  • Data drive

An NTFS volume is required. The software takes maximum 2 GB of disk space. But take into account the need for storage of temporary and production data. A backup solution is strongly advised.

Minimum screen resolutionMinimum 1280 x 1024 resolution, true color depth.
Network connection10/100/1000 Base-T Ethernet, TCP/IP v4 protocol, TCP/IP v6 protocol is not supported.
Software requirements

DeskPack for Adobe® Photoshop® requires Adobe® Photoshop®  CC 2017, CC 2018, CC 2019, or CC 20192020.

From 18.1 onwards, Adobe® Photoshop® CS6 is no longer supported. (*)

From 18.1.1 onwards, Adobe® Photoshop® CC 2017 is no longer supported and CC 2020 is supported. (*)

The 64-bit version of Adobe® Photoshop® is supported. The 32-bit version of Adobe® Photoshop® is not supported.

(*) More information on supported Adobe® Photoshop® versions can be found in the following knowledge base article: KB193116287: Do the Esko plugins (DeskPack - Dynamic Content - Studio) support the latest Adobe Creative Cloud release.

Supported Operating Systems

Tip
Recommended operating systems are highlighted in green in the tables below.


Warning

If an operating system is not listed in the tables below, it is not supported. Do not try to install DeskPack Plugins for Adobe® Photoshop® on a computer running an unsupported operating system.

Windows 10

Edition32-bit64-bit
Windows 10 Home(error)(error)
Windows 10 Pro(error)(tick)
Windows 10 Enterprise(error)(tick)

See KB170993458: Which versions of Windows 10 are supported? for more detailed information on the specific supported Windows 10 versions.

Windows 8.1

Edition32-bit

64-bit

Windows 8.1 RT(error)(error)
Windows 8.1(error)(error)
Windows 8.1 Pro(error)(tick)
Windows 8.1 Enterprise(error)(tick)

Windows 8

Edition32-bit

64-bit

Windows 8(error)(error)
Windows RT (error)(error)
Windows 8 Pro(error)(tick)
Windows 8 Enterprise(error)(tick)

Windows 7

Edition32-bit64-bit
  SP1 SP1
Windows 7 Home Basic(error)(error)(error)(error)
Windows 7 Home Premium (error)(error)(error)(error)
Windows 7 Professional(error)(error)(tick)(tick)
Windows 7 Enterprise(error)(error)(tick)(tick)
Windows 7 Ultimate(error)(error)(tick)(tick)


Note
Note that version 18.1.1 is the last version to support Windows 7.

Unsupported Operating Systems

  • Windows Vista (all editions)
  • Windows XP (all editions)
  • Windows Server 2019 (all editions)
  • Windows Server 2012 R2 (all editions)
  • Windows Server 2012 (all editions)
  • Windows Server 2008 R2 (all editions)
  • Windows Server 2008 (all editions)
  • Windows Server 2003 (all editions)
  • Windows 2000 (all editions)


System Requirements
Applies to

DeskPack Plugins for Adobe® Photoshop®

Equinox

Version18.1 and 18.1.1
Last revised

01 Mar  


Tip
titleUseful Links

Software downloads: mysoftware.esko.com


Panel
titleContents

Table of Contents
classinline-toc