Child pages
  • KB76726788: Licensing - Which product licenses enable the older versions of the software
Skip to end of metadata
Go to start of metadata

 

Question

For which products can you use newer licenses to start up older versions of the software (which licenses are backwards compatible)?

Answer

The table below gives an overview of all product versions with activation-based licenses (FlexNet). Dongle-based versions are not included.
Product
A license in a newer version...Remark
ArtiosCAD (including ArtiosCAD Standard, Enterprise, 123Box and AdvantageCAD)

Enables older versions (as of version 14.1)

For version 14 and older versions, you need dedicated 'version'-licenses.

  • During an upgrade, the license for the newer version is added to the existing licenses, so existing customers can start up older versions (as of version 7.6 in FlexNet)
  • New customers can only use the version they bought


ArtPro and PowerLayoutDoes not enable all older versions

ArtPro 18.0 license → does not enable version 16.1.0. More info here:

KB227157396: ArtPro - What has changed in version 18 licensing


ArtPro 18.1 license → oldest possible version is <16.1.0.

ArtPro 20.0 license → oldest possible version is 16.1.1. More info here:

KB289711377: Classic Editors version 20 - Upgrading ArtPro or PackEdge to version 20​


Be aware that due to security improvements, from Automation Engine 20 onwards, older versions than ArtPro 20, cannot connect to Automation Engine. More info here:

KB289712413: Improved User Management Security with version 20

ArtPro+Enables older versions (Automation Engine connection limitations as of version 20)

ArtPro+ also works with a license for ArtPro or PackEdge, you can find more info here: 

KB89427537: ArtPro+ - How licensing is handled in ArtPro+


Be aware that due to security improvements, from Automation Engine 20 onwards, older versions than ArtPro+ 20, cannot connect to Automation Engine. More info here:

KB289712413: Improved User Management Security with version 20

Automation Engine (incl Device Manager)Enables older versions


Cape Pack subscriptionEnables older versions (as of version 16)
Cape Pack (perpetual)Does not enable older versions

Color Pilot


Enables older versions

Color Engine Pilot, the predecessor of Color Pilot, does not enable older versions (During an upgrade, the license for the older version is replaced by the license for the newer version. So existing customers cannot start up older versions after an upgrade.)

DeskPack for Illustrator®Enables older versions (as of version 14)(Automation Engine connection limitations as of version 20)

With Suite 14 we introduced bundled licenses (DeskPack Essentials, DeskPack Advanced) next to licenses for individual plug-ins, those bundled licenses do not enable older versions.


DeskPack for Illustrator licenses are backwards compatible. 

Be aware that due to security improvements, from Automation Engine 20 onwards, older versions than DeskPack for Illustrator 20, cannot connect to Automation Engine. More info here:

KB289712413: Improved User Management Security with version 20


DeskPack - Version Compatibility Matrix

DeskPack for Photoshop® (Ink Tools, Flexo Tools and Equinox) Enables older versions


Dynamic Content Enables older versions

With Suite 14 we introduced bundled licenses next to licenses for individual plug-ins, those bundled licenses do not enable older versions.

FlexRip and FlexProofDoes not enable older versions

During an upgrade, the license for the older version is replaced by the license for the newer version. So existing customers cannot start up older versions after an upgrade.

Remark that version 14.0 is the last version for FlexRip/FlexProof

i-cut (Layout and Preflight)Enables older versions (Automation Engine connection limitations as of version 20)

Be aware that due to security improvements, from Automation Engine 20 onwards, older versions than i-cut-Layout 20, cannot connect to Automation Engine. More info here:

KB289712413: Improved User Management Security with version 20

Imaging Engine (including Pack Proof, Curve Pilot, Print Control Wizard)Enables older version (as of version 14)


PackEdgeDoes not enable all older versions

PackEdge 18.1 license → oldest possible version is <16.1.0.

PackEdge 20.0 license → oldest possible version is 16.1.1. More info here:

KB289711377: Classic Editors version 20 - Upgrading ArtPro or PackEdge to version 20​


Be aware that due to security improvements, from Automation Engine 20 onwards, older versions than PackEdge 20, cannot connect to Automation Engine. More info here:

KB289712413: Improved User Management Security with version 20


PlatoEnables older versions (Automation Engine connection limitations as of version 20)

Be aware that due to security improvements, from Automation Engine 20 onwards, older versions than Plato 20, cannot connect to Automation Engine. More info here:

KB289712413: Improved User Management Security with version 20

Studio (including Store Visualizer)Enables older versions 
WebCenterDoes not enable older versions
  • For version 12 or older: During an upgrade, the license for the newer version is added to the existing licenses. So existing customers can start up older versions (as of version 7 in FlexNet)
  • For version 12.1 or newer: During an upgrade, the license for the older version is replaced by the license for the newer version. So existing customers cannot start up older versions after an upgrade.


Article information
Applies to

Esko all software products

Created

 

Last revised

 

AuthorELDE
Contents