Esko Logo Back to Esko Support
Choose your language for a machine translation:
Skip to end of metadata
Go to start of metadata

Question

In June 2016, Adobe® announced an update to their Creative Cloud® with updates of Adobe® Illustrator® and Adobe® Photoshop®:

  • Adobe® Illustrator® CC 2015.3 (a.k.a. Illustrator® 20.0)
  • Adobe® Photoshop® CC 2015.5 (a.k.a. Photoshop® 17.0)

Will my Esko Plugins work with those versions?

Answer

To use an Esko plugin with any of these Adobe® products, your plugin should be of version 16 or newer. They will be available early July:

Studio 16, DeskPack 16, Dynamic Content 16, Equinox 16

These products will be available for download on mysoftware.esko.com early July.

You will also need a new license (unless you have a subscription).
Free Plugins

Free plugins (such as Data Exchange 16) will be available on www.esko.com early July.

Free Trials

The trial downloads on www.esko.com will also be updated early July. Until then, the trials will not install or work on Adobe® Illustrator® CC 2015.3 or Adobe® Photoshop® CC 2015.5.

So: If you use any Esko plugin, we strongly recommend that you wait to update your Adobe® Illustrator® or Adobe® Photoshop®, until you have version 16, your plugins and the necessary version 16 licenses.

Updating Adobe® Illustrator® or Adobe® Photoshop®

If you need to update your Adobe® application before you have compatible Esko plugins, then remember the following:

  • The Adobe® installation program will by default remove the previous version. So, to make sure that you still have a version with working plugins, please make sure to disable Remove old versions in Advanced Options. For more information, see http://adobe.ly/1SkeMvy or check this screenshot.
  • If you have already removed your previous version of Adobe® Illustrator® or Adobe® Photoshop® and you need your Esko plugins, then you will have to downgrade Adobe® Illustrator® or Adobe® Photoshop® and reinstall your Esko plugins. This blog article from Adobe® explains the downgrade process (it was written for an earlier update).
Article information
Applies to

DeskPack all versions

Studio all versions

Dynamic Content all versions

WebCenter Connector all versions

Created07-Jun-16
Last revised 
AuthorWDGR
Case Number 
Contents